re = /\|(?<boss>[A-Z]{4,})\|:#(?<title>[A-z]+ [A-z]+)#/m
str = '|IVAN|:#Master Detective#
|I|:#mammamam akjdkdj#12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end