package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\|(?<boss>[A-Z]{4,})\|:#(?<title>[A-z]+ [A-z]+)#`)
var str = `|IVAN|:#Master Detective#
|I|:#mammamam akjdkdj#12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}