using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\|(?<boss>[A-Z]{4,})\|:#(?<title>[A-z]+ [A-z]+)#";
string input = @"|IVAN|:#Master Detective#
|I|:#mammamam akjdkdj#12";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}