const regex = /\|(?<boss>[A-Z]{4,})\|:#(?<title>[A-z]+ [A-z]+)#/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|(?<boss>[A-Z]{4,})\\|:#(?<title>[A-z]+ [A-z]+)#', 'gm')
const str = `|IVAN|:#Master Detective#
|I|:#mammamam akjdkdj#12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}