$re = '/\|(?<boss>[A-Z]{4,})\|:#(?<title>[A-z]+ [A-z]+)#/m';
$str = '|IVAN|:#Master Detective#
|I|:#mammamam akjdkdj#12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);