re = /[A-Z]+\s((\/\w+)*\/)([\w\-\.]+[^#?\s]+)/m
str = 'GET /context/path/to/file.js
https://stackoverflow.com/questions/27745/getting-parts-of-a-url-regex'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end