using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]+\s((\/\w+)*\/)([\w\-\.]+[^#?\s]+)";
string input = @"GET /context/path/to/file.js
https://stackoverflow.com/questions/27745/getting-parts-of-a-url-regex";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}