$re = '/[A-Z]+\s((\/\w+)*\/)([\w\-\.]+[^#?\s]+)/m';
$str = 'GET /context/path/to/file.js
https://stackoverflow.com/questions/27745/getting-parts-of-a-url-regex';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);