import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]+\\s((\\/\\w+)*\\/)([\\w\\-\\.]+[^#?\\s]+)";
final String string = "GET /context/path/to/file.js\n\n"
+ "https://stackoverflow.com/questions/27745/getting-parts-of-a-url-regex";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}