#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Z]+\s((\/\w+)*\/)([\w\-\.]+[^#?\s]+)"
Local $sString = "GET /context/path/to/file.js" & @CRLF & _
"" & @CRLF & _
"https://stackoverflow.com/questions/27745/getting-parts-of-a-url-regex"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")