import Foundation
let pattern = #"(<time class="timeago badge-help" )(.*?)( data-livestamp="\<\?php echo )(.*?)(\; \?\>")(.*?)( title="\<\?php echo )(.*?)(\; \?\>")(>)(.*?)(<\/time\>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<time class="timeago badge-help" data-toggle="tooltip" data-livestamp="<?php echo $Image->iso_8601_modified; ?>" title="<?php echo $Image->created; ?>"><?php echo $Image->created; ?></time>
<time class="timeago badge-help" data-toggle="tooltip" data-livestamp="<?php echo $Job->iso_8601_completed; ?>" title="<?php echo $Job->completed; ?>"><?php echo $Job->completed; ?></time>
<time class="timeago badge-help" data-toggle="tooltip" data-livestamp="<?php echo $Camera->iso_8601_processed; ?>" title="<?php echo $Camera->processed; ?>"><?php echo $Camera->processed; ?></time>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<?php echo UI::timeago($4, $8); ?>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)