use strict;
my $str = ' <time class="timeago badge-help" data-toggle="tooltip" data-livestamp="<?php echo $Image->iso_8601_modified; ?>" title="<?php echo $Image->created; ?>"><?php echo $Image->created; ?></time>
<time class="timeago badge-help" data-toggle="tooltip" data-livestamp="<?php echo $Job->iso_8601_completed; ?>" title="<?php echo $Job->completed; ?>"><?php echo $Job->completed; ?></time>
<time class="timeago badge-help" data-toggle="tooltip" data-livestamp="<?php echo $Camera->iso_8601_processed; ?>" title="<?php echo $Camera->processed; ?>"><?php echo $Camera->processed; ?></time>
';
my $regex = qr/(<time class="timeago badge-help" )(.*?)( data-livestamp="\<\?php echo )(.*?)(\; \?\>")(.*?)( title="\<\?php echo )(.*?)(\; \?\>")(>)(.*?)(<\/time\>)/mp;
my $subst = '<?php echo UI::timeago($4, $8); ?>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";