import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<time class=\"timeago badge-help\" )(.*?)( data-livestamp=\"\\<\\?php echo )(.*?)(\\; \\?\\>\")(.*?)( title=\"\\<\\?php echo )(.*?)(\\; \\?\\>\")(>)(.*?)(<\\/time\\>)";
final String string = " <time class=\"timeago badge-help\" data-toggle=\"tooltip\" data-livestamp=\"<?php echo $Image->iso_8601_modified; ?>\" title=\"<?php echo $Image->created; ?>\"><?php echo $Image->created; ?></time>\n"
+ "<time class=\"timeago badge-help\" data-toggle=\"tooltip\" data-livestamp=\"<?php echo $Job->iso_8601_completed; ?>\" title=\"<?php echo $Job->completed; ?>\"><?php echo $Job->completed; ?></time>\n"
+ "<time class=\"timeago badge-help\" data-toggle=\"tooltip\" data-livestamp=\"<?php echo $Camera->iso_8601_processed; ?>\" title=\"<?php echo $Camera->processed; ?>\"><?php echo $Camera->processed; ?></time>\n"
+ " ";
final String subst = "<?php echo UI::timeago($4, $8); ?>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}