// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<time class="timeago badge-help" )(.*?)( data-livestamp="\<\?php echo )(.*?)(\; \?\>")(.*?)( title="\<\?php echo )(.*?)(\; \?\>")(>)(.*?)(<\/time\>)"#).unwrap();
let string = " <time class=\"timeago badge-help\" data-toggle=\"tooltip\" data-livestamp=\"<?php echo $Image->iso_8601_modified; ?>\" title=\"<?php echo $Image->created; ?>\"><?php echo $Image->created; ?></time>
<time class=\"timeago badge-help\" data-toggle=\"tooltip\" data-livestamp=\"<?php echo $Job->iso_8601_completed; ?>\" title=\"<?php echo $Job->completed; ?>\"><?php echo $Job->completed; ?></time>
<time class=\"timeago badge-help\" data-toggle=\"tooltip\" data-livestamp=\"<?php echo $Camera->iso_8601_processed; ?>\" title=\"<?php echo $Camera->processed; ?>\"><?php echo $Camera->processed; ?></time>
";
let substitution = "<?php echo UI::timeago($4, $8); ?>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}