import Foundation
let pattern = #"""
(?P<nested>
\b if \b
(?P<if>(?>.?(?>(?P>nested))?)*?)
(?:
\b elsif \b
(?P<elsif>(?>.?(?>(?P>nested))?)*?)
)?
(?:
\b else \b
(?P<else>(?>.?(?>(?P>nested))?)*?)
)?
\b endif \b
)?
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .allowCommentsAndWhitespace, .dotMatchesLineSeparators])
let testString = #"""
if
1
if
2
elsif
2
else
2
if
3
endif
2
endif
1
if
2
else
2
endif
1
elsif
1_elsif1_
elsif
1_elsif2_
else
1_else_
endif
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}