#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ixs)(?P<nested>" & @CRLF & _
" \b if \b" & @CRLF & _
" (?P<if>(?>.?(?>(?P>nested))?)*?)" & @CRLF & _
" (?:" & @CRLF & _
" \b elsif \b" & @CRLF & _
" (?P<elsif>(?>.?(?>(?P>nested))?)*?)" & @CRLF & _
" )?" & @CRLF & _
" (?:" & @CRLF & _
" \b else \b" & @CRLF & _
" (?P<else>(?>.?(?>(?P>nested))?)*?)" & @CRLF & _
" )?" & @CRLF & _
" \b endif \b" & @CRLF & _
")?" & @CRLF & _
""
Local $sString = "if" & @CRLF & _
" 1" & @CRLF & _
" if" & @CRLF & _
" 2" & @CRLF & _
" elsif" & @CRLF & _
" 2" & @CRLF & _
" else" & @CRLF & _
" 2" & @CRLF & _
" if" & @CRLF & _
" 3" & @CRLF & _
" endif" & @CRLF & _
" 2" & @CRLF & _
" endif" & @CRLF & _
" 1" & @CRLF & _
" if" & @CRLF & _
" 2" & @CRLF & _
" else" & @CRLF & _
" 2" & @CRLF & _
" endif" & @CRLF & _
" 1" & @CRLF & _
"elsif" & @CRLF & _
" 1_elsif1_" & @CRLF & _
"elsif" & @CRLF & _
" 1_elsif2_" & @CRLF & _
"else" & @CRLF & _
" 1_else_" & @CRLF & _
"endif"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")