package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)(?P<nested>
\b if \b
(?P<if>(?>.?(?>(?P>nested))?)*?)
(?:
\b elsif \b
(?P<elsif>(?>.?(?>(?P>nested))?)*?)
)?
(?:
\b else \b
(?P<else>(?>.?(?>(?P>nested))?)*?)
)?
\b endif \b
)?
`)
var str = `if
1
if
2
elsif
2
else
2
if
3
endif
2
endif
1
if
2
else
2
endif
1
elsif
1_elsif1_
elsif
1_elsif2_
else
1_else_
endif`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}