$re = '/(?P<nested>
\b if \b
(?P<if>(?>.?(?>(?P>nested))?)*?)
(?:
\b elsif \b
(?P<elsif>(?>.?(?>(?P>nested))?)*?)
)?
(?:
\b else \b
(?P<else>(?>.?(?>(?P>nested))?)*?)
)?
\b endif \b
)?
/ixs';
$str = 'if
1
if
2
elsif
2
else
2
if
3
endif
2
endif
1
if
2
else
2
endif
1
elsif
1_elsif1_
elsif
1_elsif2_
else
1_else_
endif';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);