// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ixs)(?P<nested>
\b if \b
(?P<if>(?>.?(?>(?P>nested))?)*?)
(?:
\b elsif \b
(?P<elsif>(?>.?(?>(?P>nested))?)*?)
)?
(?:
\b else \b
(?P<else>(?>.?(?>(?P>nested))?)*?)
)?
\b endif \b
)?
").unwrap();
let string = "if
1
if
2
elsif
2
else
2
if
3
endif
2
endif
1
if
2
else
2
endif
1
elsif
1_elsif1_
elsif
1_elsif2_
else
1_else_
endif";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}