# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)([\/](\w+))(\.(jpg|png|gif|jpeg))"
test_str = ("https://res.cloudinary.com/gametecgroup/image/upload/images_qqz2i9.jpg\n"
"https://res.cloudinary.com/gametecgroup/image/upload/images_qqz2i9.png\n"
"https://res.cloudinary.com/gametecgroup/image/upload/v1541159458/assets/img/bannerPrincipal.png\n"
"https://res.cloudinary.com/gametecgroup/image/upload/images_qqz2i9.jpg\n"
"https://res.cloudinary.com/gametecgroup/image/upload/3246234_640px_qv2lzl.jpg")
subst = ">>>> $3 <<<<< "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.