const regex = /(.*)([\/](\w+))(\.(jpg|png|gif|jpeg))/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)([\\\/](\\w+))(\\.(jpg|png|gif|jpeg))', 'mg')
const str = `https://res.cloudinary.com/gametecgroup/image/upload/images_qqz2i9.jpg
https://res.cloudinary.com/gametecgroup/image/upload/images_qqz2i9.png
https://res.cloudinary.com/gametecgroup/image/upload/v1541159458/assets/img/bannerPrincipal.png
https://res.cloudinary.com/gametecgroup/image/upload/images_qqz2i9.jpg
https://res.cloudinary.com/gametecgroup/image/upload/3246234_640px_qv2lzl.jpg`;
const subst = `>>>> $3 <<<<< `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);