use strict;
my $str = 'https://res.cloudinary.com/gametecgroup/image/upload/images_qqz2i9.jpg
https://res.cloudinary.com/gametecgroup/image/upload/images_qqz2i9.png
https://res.cloudinary.com/gametecgroup/image/upload/v1541159458/assets/img/bannerPrincipal.png
https://res.cloudinary.com/gametecgroup/image/upload/images_qqz2i9.jpg
https://res.cloudinary.com/gametecgroup/image/upload/3246234_640px_qv2lzl.jpg';
my $regex = qr/(.*)([\/](\w+))(\.(jpg|png|gif|jpeg))/mp;
my $subst = '>>>> $3 <<<<< ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";