using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)([\/](\w+))(\.(jpg|png|gif|jpeg))";
string substitution = @">>>> $3 <<<<< ";
string input = @"https://res.cloudinary.com/gametecgroup/image/upload/images_qqz2i9.jpg
https://res.cloudinary.com/gametecgroup/image/upload/images_qqz2i9.png
https://res.cloudinary.com/gametecgroup/image/upload/v1541159458/assets/img/bannerPrincipal.png
https://res.cloudinary.com/gametecgroup/image/upload/images_qqz2i9.jpg
https://res.cloudinary.com/gametecgroup/image/upload/3246234_640px_qv2lzl.jpg";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}