// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:https?:\/\/)?(?:www\.)?dai\.?ly(motion)?(?:\.com)?\/?.*(?:video|embed)?(?:.*v=|v\/|\/)([a-z0-9]+)").unwrap();
let string = "dailymotion
http://dai.ly/x578has
http://www.dailymotion.com/video/x578has_plus-difficile-que-la-pate-feuillete-et-la-frangipane-la-decoration-de-la-galette_lifestyle
http://dai.ly/x578has
Plus difficile ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}