#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:https?:\/\/)?(?:www\.)?dai\.?ly(motion)?(?:\.com)?\/?.*(?:video|embed)?(?:.*v=|v\/|\/)([a-z0-9]+)"
Local $sString = "dailymotion" & @CRLF & _
"" & @CRLF & _
"http://dai.ly/x578has" & @CRLF & _
"" & @CRLF & _
"http://www.dailymotion.com/video/x578has_plus-difficile-que-la-pate-feuillete-et-la-frangipane-la-decoration-de-la-galette_lifestyle" & @CRLF & _
"" & @CRLF & _
"http://dai.ly/x578has" & @CRLF & _
"" & @CRLF & _
"Plus difficile "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")