re = /(?:https?:\/\/)?(?:www\.)?dai\.?ly(motion)?(?:\.com)?\/?.*(?:video|embed)?(?:.*v=|v\/|\/)([a-z0-9]+)/
str = 'dailymotion
http://dai.ly/x578has
http://www.dailymotion.com/video/x578has_plus-difficile-que-la-pate-feuillete-et-la-frangipane-la-decoration-de-la-galette_lifestyle
http://dai.ly/x578has
Plus difficile '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end