use strict;
my $str = 'dailymotion
http://dai.ly/x578has
http://www.dailymotion.com/video/x578has_plus-difficile-que-la-pate-feuillete-et-la-frangipane-la-decoration-de-la-galette_lifestyle
http://dai.ly/x578has
Plus difficile ';
my $regex = qr~(?:https?:\/\/)?(?:www\.)?dai\.?ly(motion)?(?:\.com)?\/?.*(?:video|embed)?(?:.*v=|v\/|\/)([a-z0-9]+)~p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}