import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https?:\\/\\/)?(?:www\\.)?dai\\.?ly(motion)?(?:\\.com)?\\/?.*(?:video|embed)?(?:.*v=|v\\/|\\/)([a-z0-9]+)";
final String string = "dailymotion\n\n"
+ "http://dai.ly/x578has\n\n"
+ "http://www.dailymotion.com/video/x578has_plus-difficile-que-la-pate-feuillete-et-la-frangipane-la-decoration-de-la-galette_lifestyle\n\n"
+ "http://dai.ly/x578has\n\n"
+ "Plus difficile ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}