$re = '/^trigger\/(appstore|develop)-\d+\.\d+\.\d+\.\d+$/m';
$str = 'trigger/appstore-1.2.3.4
trigger/appstore-5.6.7.8
trigger/appstore-1.22.333.4444
trigger/develop-1.2.3.4
_trigger/appstore-1.2.3.4
trigger/appstore-1.2.3.4_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);