import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^trigger\\/(appstore|develop)-\\d+\\.\\d+\\.\\d+\\.\\d+$";
final String string = "trigger/appstore-1.2.3.4\n"
+ "trigger/appstore-5.6.7.8\n"
+ "trigger/appstore-1.22.333.4444\n"
+ "trigger/develop-1.2.3.4\n"
+ "_trigger/appstore-1.2.3.4\n"
+ "trigger/appstore-1.2.3.4_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}