use strict;
my $str = 'trigger/appstore-1.2.3.4
trigger/appstore-5.6.7.8
trigger/appstore-1.22.333.4444
trigger/develop-1.2.3.4
_trigger/appstore-1.2.3.4
trigger/appstore-1.2.3.4_';
my $regex = qr/^trigger\/(appstore|develop)-\d+\.\d+\.\d+\.\d+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}