using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^trigger\/(appstore|develop)-\d+\.\d+\.\d+\.\d+$";
string input = @"trigger/appstore-1.2.3.4
trigger/appstore-5.6.7.8
trigger/appstore-1.22.333.4444
trigger/develop-1.2.3.4
_trigger/appstore-1.2.3.4
trigger/appstore-1.2.3.4_";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}