package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^trigger\/(appstore|develop)-\d+\.\d+\.\d+\.\d+$`)
var str = `trigger/appstore-1.2.3.4
trigger/appstore-5.6.7.8
trigger/appstore-1.22.333.4444
trigger/develop-1.2.3.4
_trigger/appstore-1.2.3.4
trigger/appstore-1.2.3.4_`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}