import Foundation
let pattern = #"name:\s+['"]?AVP_VERSION['"]?[\s,]+value:\s+['"]?(?<currentValue>[_\-\.\w]+)['"]?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
env: [ name: AVP_VERSION, value: 1.18.1 ]
image: registry.access.redhat.com/ubi8
env:
- name: AVP_VERSION
value: "1.18.0"
command: [ sh, -c ]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)