const regex = /name:\s+['"]?AVP_VERSION['"]?[\s,]+value:\s+['"]?(?<currentValue>[_\-\.\w]+)['"]?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('name:\\s+[\'"]?AVP_VERSION[\'"]?[\\s,]+value:\\s+[\'"]?(?<currentValue>[_\\-\\.\\w]+)[\'"]?', 'gm')
const str = `env: [ name: AVP_VERSION, value: 1.18.1 ]
image: registry.access.redhat.com/ubi8
env:
- name: AVP_VERSION
value: "1.18.0"
command: [ sh, -c ]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}