$re = '/name:\s+[\'"]?AVP_VERSION[\'"]?[\s,]+value:\s+[\'"]?(?<currentValue>[_\-\.\w]+)[\'"]?/m';
$str = 'env: [ name: AVP_VERSION, value: 1.18.1 ]
image: registry.access.redhat.com/ubi8
env:
- name: AVP_VERSION
value: "1.18.0"
command: [ sh, -c ]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);