#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)name:\s+['"]?AVP_VERSION['"]?[\s,]+value:\s+['"]?(?<currentValue>[_\-\.\w]+)['"]?"
Local $sString = "env: [ name: AVP_VERSION, value: 1.18.1 ]" & @CRLF & _
" image: registry.access.redhat.com/ubi8" & @CRLF & _
" env:" & @CRLF & _
" - name: AVP_VERSION" & @CRLF & _
" value: "1.18.0"" & @CRLF & _
" command: [ sh, -c ]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")