re = /name:\s+['"]?AVP_VERSION['"]?[\s,]+value:\s+['"]?(?<currentValue>[_\-\.\w]+)['"]?/m
str = 'env: [ name: AVP_VERSION, value: 1.18.1 ]
image: registry.access.redhat.com/ubi8
env:
- name: AVP_VERSION
value: "1.18.0"
command: [ sh, -c ]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end