// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mu)(^(?<date>\d{1,2}\/\d{1,2}\/\d{1,2}),\s(?<time>\d{1,2}:\d{1,2})\s-\s(?<user>.*?):\s)|(?<word>\w+(?:\'\w+)?|[\x{1F600}-\x{1F64F}]|[\x{1F300}-\x{1F5FF}]|[\x{1F680}-\x{1F6FF}]|[\x{2600}-\x{26FF}]|[\x{2700}-\x{27BF}]|[^\w\s~"!@#$%*()_+-=¹²³§ªº`^{}[\]<>,.;:?\/\\\|\n\r\t])"#).unwrap();
let string = "3/30/20, 17:06 - Me: Hi brow! I need to test some regex.
3/30/20, 17:06 - John Doe: 👍👍👍 Let's do it!
3/30/20, 17:08 - Me: ⚡️🦄🧀🏀🤪🎺🎪💾🚽📎💕💯✅ 🇯🇵 🕔➡️👶🚴👌👽
3/30/20, 17:10 - Someone: 🐵🙈🙉🙊🐒 We're talking emoji language?
https://regex101.com/library";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}