#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)(^(?<date>\d{1,2}\/\d{1,2}\/\d{1,2}),\s(?<time>\d{1,2}:\d{1,2})\s-\s(?<user>.*?):\s)|(?<word>\w+(?:\'\w+)?|[\x{1F600}-\x{1F64F}]|[\x{1F300}-\x{1F5FF}]|[\x{1F680}-\x{1F6FF}]|[\x{2600}-\x{26FF}]|[\x{2700}-\x{27BF}]|[^\w\s~"!@#$%*()_+-=¹²³§ªº`^{}[\]<>,.;:?\/\\\|\n\r\t])"
Local $sString = "3/30/20, 17:06 - Me: Hi brow! I need to test some regex." & @CRLF & _
"3/30/20, 17:06 - John Doe: 👍👍👍 Let's do it!" & @CRLF & _
"3/30/20, 17:08 - Me: ⚡️🦄🧀🏀🤪🎺🎪💾🚽📎💕💯✅ 🇯🇵 🕔➡️👶🚴👌👽" & @CRLF & _
"3/30/20, 17:10 - Someone: 🐵🙈🙉🙊🐒 We're talking emoji language?" & @CRLF & _
"https://regex101.com/library"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")