import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(?<date>\\d{1,2}\\/\\d{1,2}\\/\\d{1,2}),\\s(?<time>\\d{1,2}:\\d{1,2})\\s-\\s(?<user>.*?):\\s)|(?<word>\\w+(?:\\'\\w+)?|[\\x{1F600}-\\x{1F64F}]|[\\x{1F300}-\\x{1F5FF}]|[\\x{1F680}-\\x{1F6FF}]|[\\x{2600}-\\x{26FF}]|[\\x{2700}-\\x{27BF}]|[^\\w\\s~\"!@#$%*()_+-=¹²³§ªº`^\\{\\}[\\]<>,.;:?\\/\\\\\\|\\n\\r\\t])";
final String string = "3/30/20, 17:06 - Me: Hi brow! I need to test some regex.\n"
+ "3/30/20, 17:06 - John Doe: 👍👍👍 Let's do it!\n"
+ "3/30/20, 17:08 - Me: ⚡️🦄🧀🏀🤪🎺🎪💾🚽📎💕💯✅ 🇯🇵 🕔➡️👶🚴👌👽\n"
+ "3/30/20, 17:10 - Someone: 🐵🙈🙉🙊🐒 We're talking emoji language?\n"
+ "https://regex101.com/library";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}