# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^(?<date>\d{1,2}\/\d{1,2}\/\d{1,2}),\s(?<time>\d{1,2}:\d{1,2})\s-\s(?<user>.*?):\s)|(?<word>\w+(?:\'\w+)?|[\x{1F600}-\x{1F64F}]|[\x{1F300}-\x{1F5FF}]|[\x{1F680}-\x{1F6FF}]|[\x{2600}-\x{26FF}]|[\x{2700}-\x{27BF}]|[^\w\s~\"!@#$%*()_+-=¹²³§ªº`^{}[\]<>,.;:?\/\\\|\n\r\t])"
test_str = ("3/30/20, 17:06 - Me: Hi brow! I need to test some regex.\n"
"3/30/20, 17:06 - John Doe: 👍👍👍 Let's do it!\n"
"3/30/20, 17:08 - Me: ⚡️🦄🧀🏀🤪🎺🎪💾🚽📎💕💯✅ 🇯🇵 🕔➡️👶🚴👌👽\n"
"3/30/20, 17:10 - Someone: 🐵🙈🙉🙊🐒 We're talking emoji language?\n"
"https://regex101.com/library")
matches = re.finditer(regex, test_str, re.MULTILINE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.