# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?<=\().+?(?=\))|(?<=\[).+?(?=\]))"
test_str = ("this is a [sample] string \n"
"with [so.me] special ((words)). and he(r)e's [[another! one]] within double brack[ets.\n"
"let's finish] this.\n\n"
"#ver 1 - \\[(.*?)\\] - catch brackets, stop if nl between brackets\n"
"#ver 2 - \\[(.*?]*)\\] - same\n"
"#ver 3 - \\[([^]]+)\\] - same, but catch even if nl between brackets\n"
"#ver 4 - \\[([^\\[\\]]*)\\] - same\n"
"#ver 5 - (?<=\\[).+?(?=\\]) - catch inside the brackets, stops at nl\n"
"#ver 6 - (\\[(?:\\[??[^\\[]*?\\])) - same as #3\n"
"#ver 7 - (?<=\\[).*?(?=\\]) - same as # 5\n"
"#ver 8 - ([[][a-z \\s]+[]]) - catch only the first, w/ brackets\n"
"#ver 9 - (?:(?<=\\().+?(?=\\))|(?<=\\[).+?(?=\\])) - same as #5 but catch () as well")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.