using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=\().+?(?=\))|(?<=\[).+?(?=\]))";
string input = @"this is a [sample] string
with [so.me] special ((words)). and he(r)e's [[another! one]] within double brack[ets.
let's finish] this.
#ver 1 - \[(.*?)\] - catch brackets, stop if nl between brackets
#ver 2 - \[(.*?]*)\] - same
#ver 3 - \[([^]]+)\] - same, but catch even if nl between brackets
#ver 4 - \[([^\[\]]*)\] - same
#ver 5 - (?<=\[).+?(?=\]) - catch inside the brackets, stops at nl
#ver 6 - (\[(?:\[??[^\[]*?\])) - same as #3
#ver 7 - (?<=\[).*?(?=\]) - same as # 5
#ver 8 - ([[][a-z \s]+[]]) - catch only the first, w/ brackets
#ver 9 - (?:(?<=\().+?(?=\))|(?<=\[).+?(?=\])) - same as #5 but catch () as well";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}