import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=\\().+?(?=\\))|(?<=\\[).+?(?=\\]))";
final String string = "this is a [sample] string \n"
+ "with [so.me] special ((words)). and he(r)e's [[another! one]] within double brack[ets.\n"
+ "let's finish] this.\n\n"
+ "#ver 1 - \\[(.*?)\\] - catch brackets, stop if nl between brackets\n"
+ "#ver 2 - \\[(.*?]*)\\] - same\n"
+ "#ver 3 - \\[([^]]+)\\] - same, but catch even if nl between brackets\n"
+ "#ver 4 - \\[([^\\[\\]]*)\\] - same\n"
+ "#ver 5 - (?<=\\[).+?(?=\\]) - catch inside the brackets, stops at nl\n"
+ "#ver 6 - (\\[(?:\\[??[^\\[]*?\\])) - same as #3\n"
+ "#ver 7 - (?<=\\[).*?(?=\\]) - same as # 5\n"
+ "#ver 8 - ([[][a-z \\s]+[]]) - catch only the first, w/ brackets\n"
+ "#ver 9 - (?:(?<=\\().+?(?=\\))|(?<=\\[).+?(?=\\])) - same as #5 but catch () as well";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}