import Foundation
let pattern = #""text"\s*:\s*"Message Id:\s*(?P<messageId>[^ ]+)\s*:\s*(?P<message>INT(?P<INT>[^ ]+)[^,]+),\s*source user"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{"source_system":"SDH","text":"Message Id: bab49ee0-afa7-11ea-811c-06d9f6b1a1c8 : INT89 API call made at timestamp : 2020-06-16T08:02:31.504 , source user: David, source system: SDH"}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)