package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"text"\s*:\s*"Message Id:\s*(?P<messageId>[^ ]+)\s*:\s*(?P<message>INT(?P<INT>[^ ]+)[^,]+),\s*source user`)
var str = `{"source_system":"SDH","text":"Message Id: bab49ee0-afa7-11ea-811c-06d9f6b1a1c8 : INT89 API call made at timestamp : 2020-06-16T08:02:31.504 , source user: David, source system: SDH"}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}