# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"text\"\s*:\s*\"Message Id:\s*(?P<messageId>[^ ]+)\s*:\s*(?P<message>INT(?P<INT>[^ ]+)[^,]+),\s*source user"
test_str = ("{\"source_system\":\"SDH\",\"text\":\"Message Id: bab49ee0-afa7-11ea-811c-06d9f6b1a1c8 : INT89 API call made at timestamp : 2020-06-16T08:02:31.504 , source user: David, source system: SDH\"}\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.