using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""text""\s*:\s*""Message Id:\s*(?P<messageId>[^ ]+)\s*:\s*(?P<message>INT(?P<INT>[^ ]+)[^,]+),\s*source user";
string input = @"{""source_system"":""SDH"",""text"":""Message Id: bab49ee0-afa7-11ea-811c-06d9f6b1a1c8 : INT89 API call made at timestamp : 2020-06-16T08:02:31.504 , source user: David, source system: SDH""}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}