const regex = /"text"\s*:\s*"Message Id:\s*(?P<messageId>[^ ]+)\s*:\s*(?P<message>INT(?P<INT>[^ ]+)[^,]+),\s*source user/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"text"\\s*:\\s*"Message Id:\\s*(?P<messageId>[^ ]+)\\s*:\\s*(?P<message>INT(?P<INT>[^ ]+)[^,]+),\\s*source user', 'gm')
const str = `{"source_system":"SDH","text":"Message Id: bab49ee0-afa7-11ea-811c-06d9f6b1a1c8 : INT89 API call made at timestamp : 2020-06-16T08:02:31.504 , source user: David, source system: SDH"}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}